The SG shows a policy map configured so that P2P traffic gets dropped between vlans 5 and 52. The task does not state to prevent P2P traffic from going BETWEEN these interfaces, rather it simply states to not send or receive P2P traffic on these interfaces.
Hence I simply created a policy matching the required protocols, and then dropped any coming in our out the interface. But would this be considered wrong in that lab?
class-map match-any P2P
match protocol kazaa2
match protocol gnutella
match protocol fasttrack
interface FastEthernet0/0
ip address 192.10.3.5 255.255.255.0
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly
ip traffic-export apply TASK7.6
speed 100
full-duplex
service-policy input BLOCKP2P
service-policy output BLOCKP2P
interface FastEthernet0/1
ip address 173.3.5.5 255.255.255.0
ip nbar protocol-discovery
ip nat inside
ip virtual-reassembly
rate-limit output access-group 162 496000 1500 2000 conform-action transmit exceed-action drop
speed 100
full-duplex
service-policy input BLOCKP2P
service-policy output BLOCKP2P