Just to share all possible variants of DMVPN.
I tested all these 6 variants and works. Documentation at Cisco is not accurate.
1 - DMVPN for IPv4 and IPv6 over IPv4 (no crypto)
HUB:
interface Tunnel0
ip address 155.1.0.5 255.255.255.0
ip mtu 1400
ip nhrp authentication cisco123
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip nhrp holdtime 300
ip tcp adjust-mss 1360
ipv6 address FE80::5 link-local
ipv6 address 2001:155:1::5/64
ipv6 mtu 1400
ipv6 tcp adjust-mss 1360
ipv6 nhrp authentication cisco123
ipv6 nhrp map multicast dynamic
ipv6 nhrp network-id 1
ipv6 nhrp holdtime 300
tunnel source GigabitEthernet1.100
tunnel mode gre multipoint
tunnel key 1
end
Spokes:
interface Tunnel0
ip address 155.1.0.1 255.255.255.0
ip mtu 1400
ip nhrp authentication cisco123
ip nhrp nhs 155.1.0.5 nbma 169.254.100.5 multicast
ip nhrp network-id 1
ip nhrp holdtime 300
ip tcp adjust-mss 1360
ipv6 address FE80::1 link-local
ipv6 address 2001:155:1::1/64
ipv6 mtu 1400
ipv6 tcp adjust-mss 1360
ipv6 nhrp authentication cisco123
ipv6 nhrp nhs 2001:155:1::5 nbma 169.254.100.5 multicast
ipv6 nhrp network-id 1
ipv6 nhrp holdtime 300
tunnel source GigabitEthernet1.100
tunnel mode gre multipoint
tunnel key 1
end
Note:
2 - DMVPN for IPv6 and IPv4 over IPv6, add/change
ip nhrp nhs 155.1.0.1 nbma 2001:169:254:100::5 multicast
ipv6 nhrp nhs 2001:155:1::5 nbma 2001:169:254:100::5 multicast
tunnel mode gre multipoint IPv6 (hub and spokes)
3 - DMVPN for only IPv4, remove IPv6 commands
4 - DMVPN for only IPv6, remove IPv4 commands and add/change
ipv6 nhrp nhs 2001:155:1::5 nbma 2001:169:254:100::5 multicast
tunnel mode gre multipoint IPv6 (hub and spokes)
5 - DMVPN for only IPv6 over IPv4, remove IPv4 commands
6 - DMVPN for only IPv4 over IPv6, remove IPv6 commands and add/change
ip nhrp nhs 155.1.0.1 nbma 2001:169:254:100::5 multicast
tunnel mode gre multipoint IPv6 (hub and spokes)