Hi Folks,
So here is my scenario. I am testing N1KV and having a jolly time with jumbo frames. In my lab I have two UCS B-200 blades running ESXi and both of these blades are VEMs inside N1KV (VEMs 21 & 22):
vem 21
host vmware id e94c609a-eed8-11e2-0000-000000000a01
vem 22
host vmware id e94c609a-eed8-11e2-0000-000000000a02
nexus1000v(config-port-prof)# sh module
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ------------------ ------------
1 0 Virtual Supervisor Module Nexus1000V ha-standby
2 0 Virtual Supervisor Module Nexus1000V active *
21 248 Virtual Ethernet Module NA ok
22 248 Virtual Ethernet Module NA ok
Now, I've enabled jumbo mtu at the global level:
hostname nexus1000v
no vlan dot1Q tag native
no system default switchport
system default switchport shutdown
system jumbomtu 9000
no logging event link-status default
no logging event trunk-status default
and I've also added 'mtu 9000' to the port profile 'SYSUPLINK-UCS-mgmt'. My port-profile looks like this:
port-profile type ethernet SYSUPLINK-UCS-mgmt
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 200,202
channel-group auto mode on mac-pinning
no shutdown
system vlan 200
state enabled
Note, that the actual mtu does not show in the pp, but on the port-channel & individual physical ports:
interface port-channel7
inherit port-profile SYSUPLINK-UCS-mgmt
vem 22
mtu 9000
interface Ethernet22/1
inherit port-profile SYSUPLINK-UCS-mgmt
mtu 9000
interface Ethernet22/2
inherit port-profile SYSUPLINK-UCS-mgmt
mtu 9000
interface Ethernet22/3
inherit port-profile SYSUPLINK-UCS-mgmt
mtu 9000
interface Ethernet22/4
inherit port-profile SYSUPLINK-UCS-mgmt
mtu 9000
nexus1000v(config-port-prof)#
However, I am wondering why, my VEM21, which is configured in exactly the same way, fails to inherit 'mtu9000'???
Below is my port-channel for VEM21 and associated physical ports (which are actually vnics in UCS btw...)
interface port-channel1
inherit port-profile SYSUPLINK-UCS-mgmt
vem 21
interface Ethernet21/1
inherit port-profile SYSUPLINK-UCS-mgmt
interface Ethernet21/2
inherit port-profile SYSUPLINK-UCS-mgmt
interface Ethernet21/3
inherit port-profile SYSUPLINK-UCS-mgmt
interface Ethernet21/4
inherit port-profile SYSUPLINK-UCS-mgmt
Both VEM 21 & 22 are using the same pp?? (They are also using the same SP template in UCS).....
It is somewhat confusing I must say!
I tried adding mtu to the port-channel, but unsurprisingly, got the following:
nexus1000v(config-port-prof)# int po1
nexus1000v(config-if)# mtu 9000
ERROR: Interface MTU cannot override MTU defined in system port-profile
nexus1000v(config-if)#
I have rebooted etc, but to no avail....
No idea, why one VEM will accept mtu from the pp and the other will not...