Well, we all know that E ports on MDS should be on dedicated rate mode, hence port-channel inherits dedicated mode.
What about F ports ,specifically when you are doing connection to UCS with f-port-channel trunking enable.
The guide here says
http://www.cisco.com/c/en/us/td/docs/switches/datacenter/mds9000/sw/6_2/configuration/guides/interfaces/nx-os/cli_interfaces/pc.html#wp1074157
Note Ports in shared rate mode cannot form a PortChannel or a trunking PortChannel.
However i'm able to do port-channel from MDS to UCS using shared rate mode.
Below samples on the same guide lists configuration for F port-channel using shared rate mode, however trunking is off
http://www.cisco.com/c/en/us/td/docs/switches/datacenter/mds9000/sw/6_2/configuration/guides/interfaces/nx-os/cli_interfaces/pc.html#wp1098440
Step 1 Enable the F port trunking and channeling protocol on the MDS core switch.
switch(config)# feature fport-channel-trunk
Step 2 Enable NPIV on the MDS core switch:
switch(config)# feature npiv
Step 3 Create the PortChannel on the MDS core switch:
switch(config)# interface port-channel 1
switch(config-if)# switchport mode F
switch(config-if)# channel mode active
switch(config-if)# switchport trunk mode off
switch(config-if)# switchport rate-mode shared
switch(config-if)# exit
Step 4 Configure the PortChannel member interfaces on the core switch:
switch(config)# interface fc2/1-3
switch(config-if)# shut
switch(config-if)# switchport mode F
switch(config-if)# switchport trunk mode off
switch(config-if)# switchport speed 4000
switch(config-if)# switchport rate-mode shared
switch(config-if)# channel-group 1
switch(config-if)# no shut
Next sample lists the same config, but with dedicated rate mode.
The only difference is that trunking mode is OFF in case of shared rate mode and it is ON in dedicated rate mode.
Does it mean that when using shared rate mode we cannot do trunking ?
Can someone confirm ?